Base library and foundation components for all Yii2 Krajee extensions.

Base library and foundation components for all Yii2 Krajee extensions.

kartik-v/yii2-krajee-base

Install

Base library and foundation components for all Yii2 Krajee extensions.

Publication time: Thursday, June 25, 2015 (4 years ago)

Created by: Visweswaran Kartik

Category: Other

Current version: 1.8.5
May 7, 2016, 10:45:52 PM (3 years ago)

Packagist: kartik-v/yii2-krajee-base

: https://github.com/kartik-v/yii2-krajee-base

: 3089546 (Per month: 78329)

Type of: Компонент


Base library and foundation components for all Yii2 Krajee extensions.

Krajee Logo
yii2-krajee-base
Donate

Stable Version Unstable Version License Total Downloads Monthly Downloads Daily Downloads

This is a base library with set of foundation classes and components used by all Yii2 extensions by Krajee. One can use this base library during creation of one’s own extensions if needed.

NOTE: This extension depends on the yiisoft/yii2-bootstrap and/or yiisoft/yii2-bootstrap4 extensions. Check the composer.json for this extension’s requirements and dependencies.

Why this extension?

To ensure a leaner code base / foundation component for use in all Krajee extensions (e.g. yii2-widgets, yii2-datecontrol, yii2-grid, yii2-dynagrid etc.). This should allow most developers to plug and play components only they need, without needing the complete suite of widgets. For example, this mitigates this issue.

Release Changes

NOTE: Refer the CHANGE LOG for details on changes to various releases.

Extension Classes

Module

Extends Yii Module class for Krajee’s Yii2 widgets and usage with translation properties enabled.

Widget

Extends Yii Widget class for Krajee’s Yii2 widgets and usage with bootstrap CSS framework.

InputWidget

Extends Yii InputWidget class for Krajee’s Yii2 widgets and usage with bootstrap CSS framework. With release v1.3.0, the Input widget automatically now attaches the following HTML5 data attribute for each input that registers jQuery plugins via registerPlugin method:

  • data-krajee-{name} the client options of the plugin. The tag {name} will be replaced with the registered jQuery plugin name (e.g. select2, typeahead etc.).

TranslationTrait

A trait for handling translation functionality using Yii’s i18n components.

BootstrapInterface

The interface that defines the constants and method signatures for bootstrap 3.x and 4.x versions that will be implemented in all classes that use BootstrapTrait.

BootstrapTrait

A trait for bootstrap 3.x and 4.x version parsing functionality for Krajee extensions (the class using this trait must implement BootstrapInterface).

AddonTrait

A trait for rendering bootstrap 3.x or 4.x input group addons.

WidgetTrait

A trait for Krajee widgets including prebuilt methods for plugin registration.

AssetBundle

Extends Yii AssetBundle class for Krajee’s Yii2 widgets with enhancements for using minimized CSS and JS based on debug mode.

PluginAssetBundle

Extension of the above AssetBundle to include dependency on Bootstrap assets and javascript plugins.

AnimateAsset

An asset bundle for loading various CSS3 animations and effects.

Html5Input

A modified input widget for rendering HTML5 inputs with bootstrap styling and input group addons for Krajee’s Yii 2 extensions.

Config

A global configuration and validation helper class for usage across Krajee’s Yii 2 extensions.

Installation

The preferred way to install this extension is through composer.

Note: Read this web tip /wiki on setting the minimum-stability settings for your application’s composer.json.

Either run

$ php composer.phar require kartik-v/yii2-krajee-base "dev-master"

or add

"kartik-v/yii2-krajee-base": "dev-master"

to the require section of your composer.json file.

License

yii2-krajee-base is released under the BSD-3-Clause License. See the bundled LICENSE.md for details.


All Comments (0)
No Comments

dev-master — May 25, 2019, 10:25:02 AM (5 months ago)

v1.1.0.x-dev — Nov 14, 2014, 10:10:10 PM (4 years ago)

v1.0.0.x-dev — Nov 9, 2014, 10:56:01 PM (5 years ago)

v2.0.5 — Mar 13, 2019, 8:14:54 PM (7 months ago)

v2.0.4 — Dec 4, 2018, 6:40:27 AM (11 months ago)

v2.0.3 — Nov 27, 2018, 6:22:26 AM (11 months ago)

v2.0.2 — Nov 26, 2018, 9:13:21 AM (11 months ago)

v2.0.1 — Nov 10, 2018, 2:06:12 PM (a year ago)

v2.0.0 — Oct 9, 2018, 10:54:35 AM (a year ago)

v1.9.9 — Sep 27, 2018, 9:02:35 PM (a year ago)

v1.9.8 — Sep 27, 2018, 6:29:34 AM (a year ago)

v1.9.7 — Sep 26, 2018, 1:46:07 PM (a year ago)

v1.9.6 — Sep 22, 2018, 10:37:15 AM (a year ago)

v1.9.5 — Sep 20, 2018, 5:19:08 PM (a year ago)

v1.9.4 — Sep 5, 2018, 9:15:03 PM (a year ago)

v1.9.3 — Aug 29, 2018, 5:57:02 AM (a year ago)

v1.9.2 — Aug 20, 2018, 9:10:23 PM (a year ago)

v1.9.1 — Aug 16, 2018, 11:17:30 AM (a year ago)

v1.9.0 — Aug 12, 2018, 11:13:37 AM (a year ago)

v1.8.9 — Sep 29, 2017, 9:18:14 AM (2 years ago)

v1.8.8 — Feb 22, 2017, 8:58:53 AM (2 years ago)

v1.8.7 — Sep 4, 2016, 12:25:29 PM (3 years ago)

v1.8.6 — Aug 19, 2016, 8:48:27 PM (3 years ago)

1.8.5 — May 7, 2016, 10:45:52 PM (3 years ago)

v1.8.4 — Apr 11, 2016, 12:07:40 PM (3 years ago)

v1.8.3 — Apr 9, 2016, 9:21:14 PM (3 years ago)

1.8.2 — Jan 10, 2016, 3:26:29 PM (3 years ago)

v1.8.1 — Dec 27, 2015, 6:42:59 PM (3 years ago)

v1.8.0 — Dec 11, 2015, 10:01:49 PM (3 years ago)

v1.7.9 — Nov 25, 2015, 10:03:35 AM (3 years ago)

v1.7.8 — Nov 22, 2015, 9:35:23 AM (3 years ago)

v1.7.7 — Jun 16, 2015, 8:19:57 AM (4 years ago)

v1.7.6 — May 9, 2015, 1:02:25 AM (4 years ago)

v1.7.5 — May 3, 2015, 11:11:52 AM (4 years ago)

v1.7.4 — Feb 13, 2015, 6:36:35 AM (4 years ago)

v1.7.3 — Jan 25, 2015, 7:21:06 PM (4 years ago)

v1.7.2 — Jan 21, 2015, 9:03:16 PM (4 years ago)

v1.7.1 — Jan 13, 2015, 10:50:02 PM (4 years ago)

v1.7.0 — Jan 12, 2015, 2:23:28 PM (4 years ago)

v1.6.0 — Dec 17, 2014, 9:15:53 AM (4 years ago)

v1.5.0 — Dec 6, 2014, 1:44:45 PM (4 years ago)

v1.4.0 — Nov 28, 2014, 10:16:36 PM (4 years ago)

v1.3.0 — Nov 25, 2014, 10:58:40 AM (4 years ago)

v1.2.0 — Nov 24, 2014, 10:00:37 PM (4 years ago)

v1.1.0 — Nov 14, 2014, 10:10:10 PM (4 years ago)

v1.0.0 — Nov 9, 2014, 10:56:01 PM (5 years ago)

Стандартная установка:

Добавьте composer.json файл вашего проекта:

"kartik-v/yii2-krajee-base": "*"

Запустите обновление зависимостей


Читать про обнолвение SkeekS CMS