Enhanced Yii2 wrapper for the bootstrap datepicker plugin

Enhanced Yii2 wrapper for the bootstrap datepicker plugin

kartik-v/yii2-widget-datepicker

Установить Демо

Enhanced Yii2 wrapper for the bootstrap datepicker plugin

Время публикации: четверг, 25 июня 2015 г. (5 лет назад)

Добавил: Visweswaran Kartik

Категория: Прочее

Актуальная версия:
1 янв. 1970 г., 3:00:00 (50 лет назад)

Packagist: kartik-v/yii2-widget-datepicker

: https://github.com/kartik-v/yii2-widget-datepicker

:

Тип: Компонент


Enhanced Yii2 wrapper for the bootstrap datepicker plugin

Krajee Logo
yii2-widget-datepicker
Donate

Stable Version Untable Version License Total Downloads Monthly Downloads Daily Downloads

The DatePicker widget is a Yii 2 wrapper for the Bootstrap DatePicker plugin with various enhancements. The plugin is a fork of Stefan Petre’s DatePicker (of eyecon.ro), with improvements by @eternicode. The widget is specially styled for Bootstrap 3 and Bootstrap 4 for Yii 2 Framework. The widget allows graceful degradation to a normal HTML text input, if the browser does not support JQuery. The widget supports these markups:

  • Simple Input Markup
  • Component Markup - Addon Prepended
  • Component Markup - Addon Appended
  • Inline / Embedded Markup
  • Date Range Markup (from and to dates)
  • Solo Button Markup

NOTE: This extension is a sub repo split of yii2-widgets. The split has been done since 08-Nov-2014 to allow developers to install this specific widget in isolation if needed. One can also use the extension the previous way with the whole suite of yii2-widgets.

Installation

The preferred way to install this extension is through composer. Check the composer.json for this extension’s requirements and dependencies. Read this web tip /wiki on setting the minimum-stability settings for your application’s composer.json.

To install, either run

$ php composer.phar require kartik-v/yii2-widget-datepicker "@dev"

or add

"kartik-v/yii2-widget-datepicker": "@dev"

to the require section of your composer.json file.

Release Changes

NOTE: Refer the CHANGE LOG for details on changes to various releases.

Demo

You can refer detailed documentation and demos on usage of the extension.

Usage

use kartik\date\DatePicker;

// usage without model
echo '<label>Check Issue Date</label>';
echo DatePicker::widget([
    'name' => 'check_issue_date', 
    'value' => date('d-M-Y', strtotime('+2 days')),
    'options' => ['placeholder' => 'Select issue date ...'],
    'pluginOptions' => [
        'format' => 'dd-M-yyyy',
        'todayHighlight' => true
    ]
]);

License

yii2-widget-datepicker is released under the BSD 3-Clause License. See the bundled LICENSE.md for details.


Все комментарии (0)
Нет комментариев

dev-master — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.4.7 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.4.6 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.4.4 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.4.3 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.4.2 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.4.1 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.4.0 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.9 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.8 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.7 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.6 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.5 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.4 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.3 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.2 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.1 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.3.0 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.2.0 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.1.0 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

v1.0.0 — 1 янв. 1970 г., 3:00:00 (50 лет назад)

Стандартная установка:

Добавьте composer.json файл вашего проекта:

"kartik-v/yii2-widget-datepicker": "*"

Запустите обновление зависимостей


Читать про обнолвение SkeekS CMS