Enhanced Yii2 wrapper for the bootstrap datepicker plugin

Enhanced Yii2 wrapper for the bootstrap datepicker plugin

kartik-v/yii2-widget-datepicker

Kartik Visweswaran

Установить Демо

Enhanced Yii2 wrapper for the bootstrap datepicker plugin
Kartik Visweswaran

Enhanced Yii2 wrapper for the bootstrap datepicker plugin (sub repo split from yii2-widgets).

@разработчик решения

Время публикации: четверг, 25 июня 2015 г. (2 года назад)

Добавил: Kartik Visweswaran

Категория: Прочее

Актуальная версия: dev-master
06 сент. 2017 г., 9:18:08 (9 месяцев назад)

Packagist: kartik-v/yii2-widget-datepicker

: https://github.com/kartik-v/yii2-widget-datepicker

: 1041727 (За месяц: 43763)

Тип: Компонент


Описание от «Kartik Visweswaran»

Enhanced Yii2 wrapper for the bootstrap datepicker plugin

yii2-widget-datepicker

Stable Version Untable Version License Total Downloads Monthly Downloads Daily Downloads

The DatePicker widget is a Yii 2 wrapper for the Bootstrap DatePicker plugin with various enhancements. The plugin is a fork of Stefan Petre’s DatePicker (of eyecon.ro), with improvements by @eternicode. The widget is specially styled for Yii framework 2.0 and Bootstrap 3 and allows graceful degradation to a normal HTML text input, if the browser does not support JQuery. The widget supports these markups:

  • Simple Input Markup
  • Component Markup - Addon Prepended
  • Component Markup - Addon Appended
  • Inline / Embedded Markup
  • Date Range Markup (from and to dates)
  • Solo Button Markup

NOTE: This extension is a sub repo split of yii2-widgets. The split has been done since 08-Nov-2014 to allow developers to install this specific widget in isolation if needed. One can also use the extension the previous way with the whole suite of yii2-widgets.

Installation

The preferred way to install this extension is through composer. Check the composer.json for this extension’s requirements and dependencies. Read this web tip /wiki on setting the minimum-stability settings for your application’s composer.json.

To install, either run

$ php composer.phar require kartik-v/yii2-widget-datepicker "@dev"

or add

"kartik-v/yii2-widget-datepicker": "@dev"

to the require section of your composer.json file.

Latest Release

NOTE: The latest version of the module is v1.4.4. Refer the CHANGE LOG for details.

Demo

You can refer detailed documentation and demos on usage of the extension.

Usage

use kartik\date\DatePicker;

// usage without model
echo '<label>Check Issue Date</label>';
echo DatePicker::widget([
    'name' => 'check_issue_date', 
    'value' => date('d-M-Y', strtotime('+2 days')),
    'options' => ['placeholder' => 'Select issue date ...'],
    'pluginOptions' => [
        'format' => 'dd-M-yyyy',
        'todayHighlight' => true
    ]
]);

License

yii2-widget-datepicker is released under the BSD 3-Clause License. See the bundled LICENSE.md for details.


Все комментарии (0)
Нет комментариев

dev-master — 06 сент. 2017 г., 9:18:08 (9 месяцев назад)

v1.4.3 — 04 сент. 2017 г., 6:28:47 (9 месяцев назад)

v1.4.2 — 04 сент. 2016 г., 13:52:50 (год назад)

v1.4.1 — 16 авг. 2016 г., 21:53:36 (год назад)

v1.4.0 — 28 июня 2016 г., 20:51:26 (год назад)

v1.3.9 — 29 марта 2016 г., 12:44:50 (2 года назад)

v1.3.8 — 25 марта 2016 г., 11:49:17 (2 года назад)

v1.3.7 — 10 янв. 2016 г., 18:14:17 (2 года назад)

v1.3.6 — 29 дек. 2015 г., 14:07:49 (2 года назад)

v1.3.5 — 28 дек. 2015 г., 8:04:19 (2 года назад)

v1.3.4 — 27 дек. 2015 г., 21:14:34 (2 года назад)

v1.3.3 — 19 июля 2015 г., 7:49:03 (2 года назад)

v1.3.2 — 02 марта 2015 г., 16:03:59 (3 года назад)

v1.3.1 — 13 февр. 2015 г., 11:20:37 (3 года назад)

v1.3.0 — 25 янв. 2015 г., 19:29:29 (3 года назад)

v1.2.0 — 04 дек. 2014 г., 12:58:33 (3 года назад)

v1.1.0 — 28 нояб. 2014 г., 22:18:20 (3 года назад)

v1.0.0 — 08 нояб. 2014 г., 21:40:45 (3 года назад)

Стандартная установка:

Добавьте composer.json файл вашего проекта:

"kartik-v/yii2-widget-datepicker": "*"

Запустите обновление зависимостей


Читать про обнолвение SkeekS CMS